资源调配配置文件不包括应用程序标识符和密钥链访问组权限

我已经尝试了所有其他的问题, 并搜索了我已经可以在这一切, 很多其他的问题涉及正在更新的现有应用程序或与开发人员帐户的人, 但这就像我第二次使用 Xcode, 它已经工作过了。 这是不知从哪里冒出来的。我不断得到这两个错误, 它允许我运行模拟器, 但不是建立在我的 iPhone 上: 1. 自动签名无法解决 "学习 Spritekit" 目标的权限问题。自动签名不能将应用程序标识符和密钥链访问组权限添加到设置配置文件中。切换到手动签名, 并通过从开发人员网站下载匹配的设置配置文件来解决此问题。或者, 要继续使用自动签名, 请从您的权利文件中删除这些权利及其相关功能。 2. 资源调配配置文件 "iOS 团队资源调配配置文件: # # # #。学习 Spritkit "不包括应用程序标识符和密钥链访问组权限。 ……

共15个回答,已解决, 标签: ios xcode
Xcode 错误 ITMS-90783: “缺少捆绑包显示名称”

今天,我开始收到 fastlane 和 Xcode 的错误: > 错误 ITMS-90783: “缺少捆绑包显示名称。缺少 Info.plist 密钥 cfbundledisplay name,或者捆绑包中有一个空值,捆绑包标识符为 “com.id”。" 没关系,我没有把这个财产移走。我认为这是苹果方面的一个 bug。 有人有同样的问题吗?你是如何解决的? ……

共6个回答,已解决, 标签: xcode testflight fastlane appstoreconnect
Xcode 10.2, Swift 5, 命令编译 Swift 失败, 同时使用发布方案构建程序

我使用的是 Xcode 10.2, Swift 5。 使用 Debug 方案时, 不会出现任何问题, 但在生成或存档时使用发布方案时, 它显示命令编译 Swift 失败, 并使用非零退出代码。 我已经尝试删除衍生数据/清洁/吊舱解体 & 吊舱安装 & 吊舱更新。这些都不管用。 enter image description here [https://i.stack.imgur.com/HYo84.jpg] [https://i.stack.imgur.com/HYo84.jpg]enter image description here [https://i.stack.imgur.com/7Op9Q.jpg] [https://i.stack.imgur.com/7Op9Q.jpg] ……

共6个回答, 标签: ios swift xcode cocoapods
需要说明,但不使用蓝牙

在我的 ios 应用程序中,苹果在部署后返回了错误:ITMS-90683: Info.plist 中缺少目的字符串与 NSBluetoothAlwaysUsageDescription。 Https://developer.apple.com/documentation/bundleresources/information_property_list/nsbluetoothalwaysusagedescription?语言 = objc [https://developer.apple.com/documentation/bundleresources/information_property_list/nsbluetoothalwaysusagedescription?language=objc] 共阅。 问题是我的应用程序中没有使用蓝牙。或者我可能不知道。我如何找出为什么需要这种许可目的? 我用的不是CoreBluetooth.framework ……

共6个回答,已解决, 标签: ios xcode permissions xcode11
更新到 xcode 11.0 后无法构建 react 本地项目

我有一个反应本地项目运行在反应本地版本 0.59.8 和 xcode 版本 10.3。不知何故,我的 xcode 更新到了 11.0 版本,之后我无法使用 react-native run-ios命令。 我已经尝试过重新清理建筑。但这没有帮助。 我收到以下错误: CoreData: 注释: 未能在路径 '/Applications/Xcode 加载优化模型。应用程序/内容/应用程序/工具。应用程序/内容/框架/工具包装。框架/版本/A/资源/XRPackageModel。 momd/XRPackageModel 9.0.omo' 错误找不到 iPhone X 模拟器。 如何解决这个问题? ……

共6个回答, 标签: ios xcode react-native core-data xcode11
需要的 iOS 12.3.1 (16F203) 支持文件

我将最新的 iOS 更新下载到我的 iPhone 7 上,并收到了这条消息 enter image description here [https://i.stack.imgur.com/RQjTy.png] [https://i.stack.imgur.com/RQjTy.png] 当我之前在 12.1 更新中遇到这种情况时我使用这个答案将文件添加到设备端口文件夹中 [https://stackoverflow.com/a/52815254/4833705]. 我一直在四处寻找,所以我找不到任何支持 12.3.1 的东西,我发现最近的是 12.2。我试过了这个答案 [https://forums.developer.apple.com/thread/115290]导致了这个答案 [https://github.com/xushuduo/Xcode-iOS-Developer-Disk-Image/issues/7#issuecomment-481993590] 但是它对我不起作用: enter image description here [https://i.stack.imgur.com/e9I ……

共5个回答,已解决, 标签: ios xcode
安装 Xcode 11-CFBundleVersion 错误后,无法在模拟器上运行应用程序

昨天下载了 Xcode 11 的测试版之后,我打开了我的项目,并尝试使用新的 Xcode 运行。不幸的是,消息出现了错误: 安装请求的应用程序失败 域名: NSPOSIXErrorDomain 代码: 22 失败原因: 应用程序的 CFBundleVersion 无效。 恢复建议: 确保您的捆绑包包含具有有效语义版本号的 CFBundleVersion。 -- 我已经关闭了 beta 版本,并尝试用最新版本的 Xcode (10.2.1) 再次运行,但是出现了同样的错误。我需要提到的是,在尝试使用 Xocde 11 运行项目之前,它在 Xcode 10 上没有任何问题。在使用 beta Xcode 运行之前和之后,没有任何变化。 我已经尝试过的: * 我已经删除了 Xcode 11 beta * 我已经清理了我的项目,并从最新的分支机构中提取了它 * 我已经从以下位置完全删除了 Xcode 10: ~/库/缓存/com.apple.dt.Xcode 图书馆/开发者 图书馆/移动设备 ~/Library/Preferences/com.apple.dt.Xcode.plist /Librar ……

共5个回答, 标签: ios xcode xcode10 xcode11
IOS-App watchOS 出版发行 CFBundleIdentifier 碰撞

应用程序上传后,我收到以下电子邮件 > 我们发现了您的应用程序 XXX 最近交付的一个或多个问题。请更正以下问题,然后重新上传。 ITMS-90806: CFBundleIdentifier-每个捆绑包必须有一个唯一的捆绑包标识符。捆绑的标识符 'org。cocoapods。CocoaLumberjack' 用于捆绑 'CocoaLumberjack。框架]” CocoaLumberjack 是一个第三方库,我在过去的很多时候都已经使用过了,没有任何问题,我很困惑。 它与框架无关。这个问题/答案中指定的 plist 关键字 CFBundlePackageType框架冲突 [https://stackoverflow.com/questions/31990871/framework-cfbundleidentifier-collision] 。CocoaLumberjack 捆绑包的类型是 “框架” (CFBundlePackageType = FMWK)。CocoaLumberjack 是一个使用 cocoapods 添加到我的项目中的广泛使用的第三方库。 这个问题可能与我的应用程序包中的 wat ……

共5个回答,已解决, 标签: ios xcode cocoapods watch-os
如何修复 XCODE 10.2 中的 "SWIFT _ VERSION ' 3.0 ' 不受支持, 支持的版本是: 4.0, 4.2, 5.0" 错误?

我尝试运行从应用程序下载, 尝试在 Xcode 中打开, 并有一个错误: "显示最近的消息:-1: swift _ VERSION ' 3.0 ' 不受支持, 支持的版本是: 4.0, 4.2, 5.0。(在目标 ' 简单天气 ' 中) "如何解决这个问题? ……

共4个回答, 标签: xcode swift3
如何上传 IPA 现在应用程序加载程序不再包含在 Xcode 11 中

我有点害怕问这个问题,因为这个问题对我来说似乎很大,但是我没有看到任何人对此感到恐慌。我有点害怕听起来疯狂,但我会去做: 正如我们可以在苹果的帖子中读到的提交更新 [https://developer.apple.com/app-store-connect/whats-new/?id=submissionsupdate9-10] : > 从 Xcode 11 开始,应用程序加载器不再包含在 Xcode 中。有关如何使用 Xcode 将应用程序上传到应用商店 Connect 的详细信息,请参见 Xcode 帮助。 对于使用 phonegap 构建服务的人和组织来说,知道我们无法访问 Xcode 项目文件,询问自己如何将 IPA 放在网上是合法的。 苹果给了我们一个新工具叫做档案组织者但是正如我们可以在文档 [https://help.apple.com/xcode/mac/current/#/dev442d7f2ca]: > 在 “存档管理器” 中,选择要上传的存档,然后单击 “分发应用”。 好吧,伙计,我的档案在哪里?IPA 被认为是档案吗?如何将我的 IPA 集成到这个软件中? 也许我还 ……

共4个回答,已解决, 标签: xcode phonegap-build phonegap xcode11 application-loader
Xcode 11 beta 7 下载链接后面的 Xcode 11 beta 6?

我已经尝试下载了几次 Xcode beta 版本,该版本应该是支持 iOS 13.1 beta 的 Xcode 11 beta 7。我正在从这个链接下载它: Https://download.developer.apple.com/Developer_Tools/Xcode_11_Beta_7/Xcode_11_Beta_7.xip [https://download.developer.apple.com/Developer_Tools/Xcode_11_Beta_7/Xcode_11_Beta_7.xip] 此外,拆包时,很明显,它是在拆包 Xcode 11 beta 7: enter image description here [https://i.stack.imgur.com/GYJbo.png] [https://i.stack.imgur.com/GYJbo.png] 但打开后 (8月27日 23:05 左右),我看到以下内容: enter image description here [https://i.stack.imgur.com/ZSw17.png] [https://i.s ……

共3个回答,已解决, 标签: xcode xcode11
ITMS-90809: 不推荐使用 API-Apple 将停止接受使用 UIWebView API 的应用程序的提交

昨天,我将我的应用程序上传到 TestFlight,过了一会儿,苹果给我发了这个警告: ITMS-90809: 不推荐使用 API-Apple 将停止接受使用 UIWebView API 的应用程序的提交。见 Https://developer.apple.com/documentation/uikit/uiwebview [https://developer.apple.com/documentation/uikit/uiwebview]了解更多信息。 问题是,我在我的应用程序中不使用 UIWebView,所以我试图更新我的 pods,但仍然是同样的事情。顺便说一句,这是我在 TestFlight 上的第3 版本,这是苹果第一次给我发送这个。有什么想法吗? 更新 这是我的豆荚: 消防/核心舱 荚 'Firebase/Firestore' Pod 'firebase/mlvision' Pod 'firebase/mlvisiontextmodel' 荚 'SVProgressHUD' Pod 'sppermission/camer' Pod 'sppermission/photol' 曼蒂斯号 荚 ……

共3个回答,已解决, 标签: ios swift xcode
Xcode 10.2 gnu 样式的内联程序集被禁用

今天, 在更新 Xcode 并安装 macOS 更新后, 出现了以前不存在的错误。 我的监视扩展应用程序现在包含错误: 可禁用 gnu 风格的内联enter image description here [https://i.stack.imgur.com/lFjAF.png] [https://i.stack.imgur.com/lFjAF.png]程序集:enter image description here [https://i.stack.imgur.com/MKoYH.png] [https://i.stack.imgur.com/MKoYH.png] * 无法生成模块 "_ 内置" * 无法生成模块 "simd" * 无法构建模块 "场景套件" * 无法构建模块 "监视套件" 我还没有找到为什么会这样的答案。在设备上, 它工作正常。模拟器甚至不构建。 这些应用程序使用观辛软件 2.0 & iOS 9.0。 ……

共2个回答,已解决, 标签: ios xcode
没有为-lRCTGeolocation 找到图书馆

已经安装了 react-native-firebase & 我正在使用我的 project.Xc工作区在 iOS 上使用 Xcode 进行构建,当我只安装 auth & core 包时,这很好。当我安装消息传递包时,无论如何,我都会收到错误 “找不到-lRCTGeolocation 的库”。有人能帮我吗? 反应-土特产: 0.60.3 反应-土生土长的炮兵阵地: 5.5.4 Thansk 提前。 我从 pod 文件中删除了消息传递引用,我删除了 pods 文件夹和 podfile.lock 文件,重新安装了 pods,清理了构建,但没有解决。 ……

共2个回答,已解决, 标签: ios xcode react-native react-native-firebase pod
应用商店在安装 Xcode 11 beta 并保留 Xcode 10.2 后拒绝我的更新

我安装了 Xcode beta 11 并保留了 10.2 版本,我提交了我的应用程序供审查,但是即使我用 Xcode 10.2 构建,我也会得到无效的二进制文件。我甚至卸载了 Xcode 11 beta 和同样的东西。我不知道下一步该怎么做 > ITMS-90111: 无效的工具链 -- 你的应用程序是用 Xcode 或 SDK 的测试版本构建的。提交给应用商店的应用程序必须使用 Xcode 9 的 GM 版本和 iOS 11 、 tvOS 11 、 watchOS 4 或 macOS 10.13 或更高版本的 SDK 来构建。 ……

共2个回答,已解决, 标签: xcode
Xcode "使用未声明的类型 ' 某些类 '" 错误, 但生成成功

我已经看到这个问题问过几次, 就像这里 [https://stackoverflow.com/questions/32948472/error-use-of-undeclared-type-nsobject-in-xcode] 和这里 [https://stackoverflow.com/questions/12150024/xcode-use-of-undeclared-identifier-errors-compiles-runs-just-fine] 一样, 但我所查找的所有问题似乎都已经过时, 或者有了与我所遇到的问题不一致的答案。 我有两个框架--一个有一些类进行处理 (让我们称之为 ProcessingLibrary ), 第二个框架利用我的处理框架。 在 ProcessingLibrary 框架中, 我有一个公共类在一个快速的文件中声明, 如下所示: public class SomeClass { public init(_ stuff: String) { // do stuff } ... 它建立了一切都很美, 生活也是美好的。 然后在 ……

共2个回答, 标签: ios swift xcode
Xcode 11 beta 4 错误: 命令编译使用非零退出代码失败

我已经下载了最新的 XCode beta 4。当我构建时,我的 3 个豆荚也出现了同样的错误: 命令编译失败,退出代码为非零 : 0: 错误: 未知参数: '-w' : 0: 错误: 未知参数: '-xanalyz' : 0: 错误: 未知参数: '-分析器-禁用-所有检查' 这是 MarqueeLabel pod 日志:enter image description here [https://i.stack.imgur.com/Hdkd2.png] [https://i.stack.imgur.com/Hdkd2.png] 我试过了: * 清洁和深度清洁 (切换 alt cmd k) * 删除导出的数据文件夹 * 重启 Xcode 我看不到发布说明中列出的错误。 Https://developer.apple.com/documentation/xcode_release_notes/xcode_11_beta_4_release_notes [https://developer.apple.com/documentation/xcode_release_notes/xcode_11_b ……

共2个回答,已解决, 标签: xcode xcode11
将 Xcode 更新到 10.3 (10G8) 版本后,故事板破裂 & 应用程序不再运行

我刚刚将 Xcode 更新到 10.3 (10G8) 版本。 现在,我的项目没有运行,出现以下错误:enter image description here [https://i.stack.imgur.com/vShwj.png] /* Com.apple.actool.错误 */ : 错误: 未能找到适合 ibsimdevicpeipad2x (com) 类型的设备苹果。 dt。 xcode。 ibsimdevice type。运行时 iOS 12.4 (12.4-16G73)-com 的 iPad-2x)。苹果。核心模拟器。 simRuntime。 iOS-12-4 故障原因: 无法创建与 ibsimdevicpeipad2x (com) 匹配的新模拟器设备苹果。 dt。 xcode。 ibsimdevice type。运行时 iOS 12.4 (12.4-16G73)-com 的 iPad-2x)。苹果。核心模拟器。 simRuntime。 iOS-12-4 (无效运行时: com。苹果。核心模拟器。 simRuntime。 iOS-12-4 潜在错误: 描述: 无效运行时: com.apple. ……

共1个回答,已解决, 标签: xcode storyboard
共享应用程序 openURL

我有一个混合应用程序,它有一个只有 AppDelegate 类的 iOS obj-c case proj,所有其他逻辑都是在混合应用程序中开发的。 OpenURL 在混合应用程序中有多种用法。我需要的: 1. 在 iOS 应用程序 (AppDelegate) 的情况下处理 openURL 委托 2. 我可以更改所有网址吗?(在 AppDelegate 中) 3. 我可以覆盖[[UIApplication sharedApplication] openURL] ……

共1个回答, 标签: ios xcode appdelegate uiapplicationdelegate openurl
缺少支持文件的 xcode ios 12.2 (16E227)

我的设备正在运行 iOS 12.2, 但最新的 Xcode 版本 (在商店上, 直接从开发人员. apple, 这只是推送我到商店) 不提供该 iOS 版本的支持文件, 所以我无法构建到设备。 以下是来自 Xcode 的错误消息: enter image description here [https://i.stack.imgur.com/dmXBD.png] [https://i.stack.imgur.com/dmXBD.png] 我的 Xcode 构建在 macOS Mojava 上运行 v.10.14: enter image description here [https://i.stack.imgur.com/Y40p9.png] [https://i.stack.imgur.com/Y40p9.png] 是否有任何信誉良好的其他地方下载一个较新的 Xcode 测试版 (或只是支持文件, 在 Xcode > 内容 > 开发人员 > 平台 > iphoneos. 平台 > 设计支持), 或者我在这里错过了一些东西? ……

共1个回答,已解决, 标签: ios xcode