类型错误: clean webpackplugin 不是构造函数

我试图通过 webpack-server-dev.I 预览 vue web 应用程序 Https://medium.com/the-web-tub/creating-your-first-vue-js-pwa-project-22f7c552fb34 [https://medium.com/the-web-tub/creating-your-first-vue-js-pwa-project-22f7c552fb34] 该指南解释说,插件用于删除 dist 目录中的旧文件和未使用的文件。我已经试过更换了const CleanWebpackPlugin = require('clean-webpack-plugin') with const { CleanWebpackPlugin } = require('clean-webpack-plugin')一些帖子建议这样做。我也尝试过查看上的文档 Https://github.com/johnagan/clean-webpack-plugin [https://github.com/johnagan/clean-webpack-plugin]但是没有成功,因为我对 ……

共4个回答, 标签: javascript vue.js webpack webpack-dev-server
Postcss-svgo: TypeError: 无法设置未定义 (盖茨比) 的属性 “multiscont”

在盖茨比 2.17.6 项目中,当构建时: > 构建生产 JavaScript 和 CSS 捆绑包 [= ] 1.940 s 1/6 17% 运行查询失败构建生产 JavaScript 和 CSS 包-75.519 s 错误 #98123 WEBPACK 生成 JavaScript 捆绑包失败 Postcss-svgo: TypeError: 无法设置 未定义 未完成运行查询-77.639 s npm ERR!代码 ELIFECYCLE npm ERR!Errno 1 npm ERR! Gatsby-starter-default@1.0.0 [gatsby-starter-default@1.0.0]构建: node _ modules/gatsby/dist/bin/gatsby.js 构建 npm ERR!退出状态 1 这些是我的一些依赖: “依赖关系”: { “Babel-插件风格-组件”: “^ 1.8.0”, : “盖茨比”: “^ 2.0.19”, “盖茨比-插件-favicon”: “^ 3.1.4”, “盖茨比-插件-谷歌字体”: “0.0.4”, “盖茨比-离线插件”: “ ……

共4个回答, 标签: node.js webpack redhat gatsby postcss
Webpack 文件加载器输出 [目标模块]

我正在使用 webpackHtmlWebpackPlugin, html-loader and file-loader. I have a simple project structure in which I use no frameworks, but only typescript. Thus, I write my HTML code directly to index.html. I also use this HTML file as my template in HtmlWebpackPlugin。 正如所有网站一样,我需要在我的资产文件夹中放置一个引用 PNG 的图像。file-loader should load the file correctly put the new filename inside the src tag but that is not what is happening. Instead, as the value of src tag, I have [object Module]. I assume the file-loader emits some ob ……

共4个回答,已解决, 标签: javascript html webpack
vuejs npm 开发服务器不显示更新的输出

我在文字新闻主题中使用 vuejs, 一切都设置正确, 工作正常。 npm run build完美地工作, 并创建区和文字新闻拿起它的所有内容。 那么, 有什么问题呢? npm run dev也在控制台中工作, 但当我在 vue 模板中进行了任何更改时, 它将编译, 但它不会显示更新的输出。 请指导和帮助。 webpack.config.dev.js const path = require('path'); const webpack = require('webpack'); const StyleLintPlugin = require('stylelint-webpack-plugin'); const fs = require('fs'); const autoprefixer = require('autoprefixer'); if (fs.existsSync(path.resolve(__dirname, '../.env.example')) === true) { fs.renameSync( path.resolve(__dirname, '../.e ……

共1个回答, 标签: javascript node.js vue.js webpack vuejs2
控制 Ionic3 中的包捆绑

我在节点 _ 模块中有很多东西, 从我所能看出的情况来看, vendor.js 当我构建我的 Ionic3 项目时, 所有这些东西最终都会出现。为了简单起见, 假设我在节点 _ 模块中有以下文件夹: abc、xyz、uvw 和 qrs. 让我们进一步说, abc 和 xyz 是公共图书馆, 但 uvw 和 qrs 是私有库。因此, 我希望最终没有一个 vendor.js 包含所有四个库的单一。相反, 我想最终 vendor.js 得到一个包括 abc 和 xyz 的, 一个 private.js 包括 uvw 和 qrs 的。 如何更改 Ionic3 项目中的配置文件以实现该结果?理想情况下, 我只需在配置中命名 uvw 和 qrs, 并为节点 _ 模块中的 "其他一切" 生成 vendor. js 的默认行为。 更新功能作为参考, Ionic 3.9.2 使用了 Webpack 3.10.0, 默认的 Ionic web 包配置如下所示。我真的只关心做我上面描述的行为的生产构建。 /* * The webpack config exports an object that has a valid w ……

共1个回答, 标签: webpack ionic3
根级别的 Angular 代理

我有一个用 jQuery 编写的 Angular 应用程序和一个登陆页面。 每次请求在的根目录上时,我都想为登陆页面提供服务Http://mywebsite.com。让我们说,还有什么 Http://mywebsite.com/otherpage,我想为 Angular 的应用程序服务。 与Nginx(生产),这是相当容易的。 开发 Angular 时,我们可以很容易地代理其他请求,比如/Api,与-代理-配置代理。配置。 jsonCLI 选项。 我遇到的问题是根级别。 我做错了什么?我不能代理根级别吗? Angular 文档 [https://angular.io/guide/build#proxying-to-a-backend-server]告诉我们去Web pack 开发-服务器文档 [https://webpack.js.org/configuration/dev-server/#devserver-proxy] 但是我还是不知道该怎么做。 我的代理。配置。 json如下所示: { 【/Api/* 】: { “目标”: “http://localhost: 3000”, “安全”: ……

共1个回答, 标签: angular webpack webpack-dev-server
当我在 vue.js 中运行 npm 时,错误接口 “noderequire” 不能同时扩展类型 “require”

C:/phpStudy2018/phpturation/WWW/Tms.Web/node _ modules/@ types/node/globals.d.ts (139,11) 中的错误: 139: 11 接口 'noderequire' 不能同时扩展类型 '要求' 和 '要求功能'。 类型 “require” 和 “requirefunction” 的命名属性 “cache” 不相同。 137 | 138 |//向后可压缩 > 139 | 接口 NodeRequire 扩展 NodeJS.Require {} | ^ 140 | 接口 RequireResolve 扩展 NodeJS.RequireResolve {} 141 | 接口 NodeModule 扩展 NodeJS.Module {} 142 | C:/phpStudy2018/phpturation/WWW/Tms.Web/node _ modules/@ types/node/globals.d.ts 中的错误 C:/phpStudy2018/phpturation/WWW/Tms.Web/node _ modules/@ types ……

共1个回答, 标签: typescript vue.js webpack
如何让我的 react 应用程序仍然在 lint 错误下运行?

我正在使用 webpack 开发一个 React 应用程序,当我运行 “npm start” 时,构建需要很长时间, 但是,如果有 lint 错误,它将在构建结束时以 “退出状态 1” 失败,我需要修复错误,然后运行 “npm start”。 错误是像 “未使用的 var” 、 “线路太长” 等。所以他们不应该阻止应用程序运行,也浪费了我等待它再次构建的时间。 我仍然希望看到 lint 错误,但是如何阻止它们导致构建退出? ……

共0个回答, 标签: reactjs npm webpack visual-studio-code