未创建的会话: 此版本的 ChromeDriver 仅支持 Chrome 版本74错误, ChromeDriver chrome 使用硒

我试图使用 rsDriver 函数运行 RsDriver, 但当我运行 rD <- rsDriver() 时, 我会收到一条消息, 告诉我我需要一个较新版本的 chrome: > rD <- rsDriver() checking Selenium Server versions: BEGIN: PREDOWNLOAD BEGIN: DOWNLOAD BEGIN: POSTDOWNLOAD checking chromedriver versions: BEGIN: PREDOWNLOAD BEGIN: DOWNLOAD BEGIN: POSTDOWNLOAD checking geckodriver versions: BEGIN: PREDOWNLOAD BEGIN: DOWNLOAD BEGIN: POSTDOWNLOAD checking phantomjs versions: BEGIN: PREDOWNLOAD BEGIN: DOWNLOAD BEGIN: POSTDOWNLOAD [1] "Connecting to remote server" Selenium message:sessi ……

共6个回答,已解决, 标签: r selenium google-chrome selenium-chromedriver rselenium
存储库 "http://dl.google.com/linux/chrome/deb 稳定的版本" 未签名

我有以下步骤在我的 CircleCi 设置安装谷歌 Chrome: - run: name: Install Chrome headless working_directory: / command: | wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | apt-key add - && \ echo "deb http://dl.google.com/linux/chrome/deb/ stable main" > /etc/apt/sources.list.d/google.list && \ apt-get update && \ apt-get install -y dbus-x11 google-chrome-unstable && \ rm -rf /var/lib/apt/lists/* 它停止工作, 并返回以下错误消息: W: GPG error: http://d ……

共4个回答, 标签: linux google-chrome ubuntu apt
如何在 chromedriver 中关闭 w3c 以解决错误未知命令: 在 W3C 中不能调用非 W3C 标准命令

Chrome 75 版本刚刚发布,我们的测试不再正常运行。他们给出了粘贴在下面的 stacktrace。我们将 ruby on rails v.5.1.6.2 与 rspec 、 selenium-webdriver 3.0 一起使用。 Stacktrace: Selenium:: WebDriver:: 错误:: 未知 未知命令: 在 W3C 模式下不能调用非 W3C 标准命令 #0 chromedriver 0x 000000010c46 e8e9 chromedriver 3594473 #1 chromedriver 0x 000000010c3fe543 chromedriver 3134787 #2 chromedriver 0x 000000010c1aa29f chromedriver 692895 #3 chromedriver 0x 000000010c11a691 chromedriver 104081 #4 chromedriver 0x 000000010c11b75 chromedriver 108501 # 月 chromedriver 0x000000010c42d555 ……

无法隐藏 Chrome v76 中的 &ldquo;Chrome 正在被自动化软件控制&rdquo; 信息框

将 Chrome 更新到 76 版后,我不知道如何隐藏 “Chrome 正在被自动化软件控制”.“覆盖页面上某些控件的通知。 最新稳定版 76.0.3809.68 ChromeDriver 是确实的。以下代码与 Chrome 75 和 ChromeDriver 74 一起使用。 Var 选项 = 新的 ChromeOptions (); 选项.AddArgument ("-- test-type"); 选项。AddArgument (“-禁用-扩展”); 选项。添加参数 (“禁用-信息栏”); 选项。添加参数 (“-禁用-通知”); 选项。添加参数 (“启用-自动化”); 选项。AddArguments (“-禁用-弹出-阻止”); 选项。添加参数 (“开始最大化”); Var 驱动程序 = 新的 ChromeDriver (驱动程序位置、选项、脚本超时); ……

最新版本的谷歌 Chrome, 73.0, 网页应用程序的溢出不再起作用

最新版本的谷歌 Chrome, 73.0, 网页应用程序的溢出不再使用, 而不指定高度100% 的容器。这是个虫子吗? ……

共2个回答, 标签: html css google-chrome scroll overflow