Xcode 10.2, Swift 5, 命令编译 Swift 失败, 同时使用发布方案构建程序

我使用的是 Xcode 10.2, Swift 5。 使用 Debug 方案时, 不会出现任何问题, 但在生成或存档时使用发布方案时, 它显示命令编译 Swift 失败, 并使用非零退出代码。 我已经尝试删除衍生数据/清洁/吊舱解体 & 吊舱安装 & 吊舱更新。这些都不管用。 enter image description here [https://i.stack.imgur.com/HYo84.jpg] [https://i.stack.imgur.com/HYo84.jpg]enter image description here [https://i.stack.imgur.com/7Op9Q.jpg] [https://i.stack.imgur.com/7Op9Q.jpg] ……

共6个回答, 标签: ios swift xcode cocoapods
Stuck-本地安装所需的 CocoaPods 依赖关系被卡住

我无法完成 react-native init,因为这个过程一直停留在安装所需的 cocoapods 依赖项上。请帮助 这是终端中显示的几个部分: 【 4/4 】建造新鲜的包裹. 成功保存了锁定文件。 成功保存了 48 个新依赖项。 ├─ @ 通天/core@7.5.0 ├─ @ 通天/runtime@7.5.0 @ React-本地社区/eslint-config@0.0.5 类型/eslint-visitor-keys@1.0.0 ── @ 打字稿-eslint/eslint-plugin@1.11.0 ── @ 打字稿-eslint/experimental-utils@1.11.0 ── @ 打字稿-eslint/parser@1.11.0 ── @ 打字稿-eslint/typescript-estree@1.11.0 ── Acorn-jsx@5.0.1 ── Acorn@6.2.0 ── Ajv@6.10.0 ── Babel-jest@24.8.0 ── Chardet@0.7.0 ── Doctrine@3.0.0 ── Emoji-regex@7.0.3 ── Eslint-scope ……

共5个回答, 标签: react-native cocoapods
IOS-App watchOS 出版发行 CFBundleIdentifier 碰撞

应用程序上传后,我收到以下电子邮件 > 我们发现了您的应用程序 XXX 最近交付的一个或多个问题。请更正以下问题,然后重新上传。 ITMS-90806: CFBundleIdentifier-每个捆绑包必须有一个唯一的捆绑包标识符。捆绑的标识符 'org。cocoapods。CocoaLumberjack' 用于捆绑 'CocoaLumberjack。框架]” CocoaLumberjack 是一个第三方库,我在过去的很多时候都已经使用过了,没有任何问题,我很困惑。 它与框架无关。这个问题/答案中指定的 plist 关键字 CFBundlePackageType框架冲突 [https://stackoverflow.com/questions/31990871/framework-cfbundleidentifier-collision] 。CocoaLumberjack 捆绑包的类型是 “框架” (CFBundlePackageType = FMWK)。CocoaLumberjack 是一个使用 cocoapods 添加到我的项目中的广泛使用的第三方库。 这个问题可能与我的应用程序包中的 wat ……

共5个回答,已解决, 标签: ios xcode cocoapods watch-os