Terraform azurerm 2.X 错误: “功能”: 未设置必填字段

共2个回答, 标签: azure terraform

所以 azurerm 几个小时前更新到 2.0.

我的主要代码是为了安全而锁定的版本, 但是我正在做一些测试,看看 1.44 的公共测试版有什么变化,现在除了 terraform init 之外,我在任何 TF 命令上都遇到了以下错误。

还有其他人想到这个吗?

第1个答案
第2个答案
    You could also fix the azurerm provider version to the last stable version 1.44:
提供商 “azurerm” {
Version = "~> 1.44"
}

相关问题

Azure 的 web 应用程序。Net core 3.0,失败,找不到 Microsoft.AspNetCore.App [警告] 找不到键的 loc 字符串: CorrelationIdForARM Terraform azurerm 2.X 错误: “功能”: 未设置必填字段