如何修复 Vuejs 中的 “webpack Dev Server 无效选项”

共6个回答,已解决, 标签: vuejs2 webpack-dev-server

我正在使用@ Vue/cli v3.7.0我创建了一个项目创建 myappBabel 路由器节点 sass 和我的项目安装成功

但是当我运行 npm run serve (在项目目录中) 时,我收到了以下错误:


启动开发服务器的信息.
错误验证错误: webpack Dev 服务器无效选项

选项。客户端日志级别应为 {String},等于允许的值之一

[“信息” 、 “战争” 、 “错误” 、 “调试” 、 “跟踪” 、 “沉默”]

(Https://webpack.js.org/configuration/dev-server/#devserverclientloglevel)

验证错误: webpack Dev 服务器无效选项

选项。客户端日志级别应为 {String},等于允许的值之一

[“信息” 、 “战争” 、 “错误” 、 “调试” 、 “跟踪” 、 “沉默”]

(Https://webpack.js.org/configuration/dev-server/#devserverclientloglevel)

在验证选项 (C: \ 用户 \ 戴尔 \ 桌面 \ myapp \ node_modules \ webpack-dev-server \ node_modules \ 模式-实用程序 \ src \ 验证选项
在新服务器上 (C: \ Users \ Dell \ Desktop \ myapp \ node_modules \ webpack-dev-Server \ lib \ server.js: 71: 5)
在服务 (C: \ Users \ 戴尔 \ 桌面 \ 您的主要组件是myapp.exe,'node_modules \ @ vue \ cli-服务 \ lib \ 命令 \ 服务。记者: 138: 月)
在 process._ tickCallback (内部/流程/next _ tick.js: 68: 7)
在功能。模块。 runMain (内部/模块/cjs/loader。js: 757: 11)
启动时 (内部/引导/node.js: 283: 19)
在 bootnodenodejscore (内部/引导/node.js: 622: 3)
新公共管理错误!代码 ELIFECYCLE
新公共管理错误!Errno 月
Myapp@0.1.0 服务: vue-cli-服务服务
新公共管理错误!退出状态 1
新公共管理错误!
新公共管理错误!Myapp@0.1.0 服务脚本失败。
新公共管理错误!这可能不是 npm 的问题。上面可能有额外的日志输出。

新公共管理错误!可以在以下位置找到此运行的完整日志:
新公共管理错误!C: \ 用户 \ 戴尔 \ AppData \ 漫游 \ Roaming-cache \ _ 日志 \ 2019-05-17t19 _ 40 _ 14 _ 98-调试日志

我试过了缓存清理-f,VueJS 的重新安装,项目的重新安装,但没有任何效果:

我期待我的新公共管理运行服务工作!

第1个答案(采用)

是的,这个问题在过去的几个小时里刚刚出现@ Vue/cli。我在一个新项目中也有同样的事情。要修复它,请尝试以下操作:

  1. 在项目的根中创建一个名为Vue.config.js如果你还没有那个文件。

  2. 将此添加到该文件中:

模块.导出 = {
DevServer: {
ClientLogLevel: 'info'
}
};

然后重新运行你的项目。昨晚发生了一件事ClientLogLevel预设的值变得不正确。

这里有一个关于这个问题的线索:GitHub.

第2个答案

我不知道你为什么会出现这个错误,但是下面是你如何配置这个选项:

1. 创建Vue.config.js在您的根目录中

2. 在其中输入以下内容:

模块.导出 = {
DevServer: {
ClientLogLevel: 'debug'
}
}

3. 重新运行新公共管理运行服务

您可以阅读有关配置开发服务器的更多信息这里.

第3个答案

好像是Webpack-dev-server@3.4.0坏了什么我把它还原为3.3.1它似乎在工作。

第4个答案

使用时,文档有点混乱@ Cli/cli-服务因为它基本上包装了 webpack。

[这里是解决方案的链接] ( Https://cli.vuejs.org/guide/webpack.html#simple-configuration)

最好的办法是更新你的Config.js像这样的东西

ConfigureWebpack: {
DevServer: {
客户端日志级别: “沉默”,
},
},
第5个答案

我编辑

Node_modules/@ vue/cli-服务/演讲稿/命令/服务.js

所以 139 行说:

ClientLogLevel: 'warn'

而不是

ClientLogLevel: 'none'

(编辑 -- 尽管我正在使用 hello-world 应用程序)

第6个答案

Webpack-dev-server 已经作为 v3.4.1 发布,用于修补程序。 请更新。 Https://github.com/webpack/webpack-dev-server/releases/tag/v3.4.1

相关问题

如何修复 Vuejs 中的 “webpack Dev Server 无效选项” Laravel 中的 VUE2 组件寄存器 vuejs npm 开发服务器不显示更新的输出 类型错误: clean webpackplugin 不是构造函数 根级别的 Angular 代理